DMX Music Visualization Help

 

Shortened manual

 

 

 

 

Version 1.8

 

Copyright ã 2009

Documentation by:
Ing. Jaroslav Nušl, Bc. Ondøej Chytra,
Ing. Hanka Holubinková, Bc. Michal Kazda

 

Web site: www.soh.cz



Contents

 

Contents. 2

1       Sound card setting. 5

2       Adding an attribute (effect, symptom) 8

3       Attribute Setting. 9

4       How an attribute affects a scene or a chase. 12

4.1      Assigning of one DMX channel 12

4.2      Scene assigning. 12

4.3      Chase assigning. 13

4.4      Assigning of symbols # and ##. 15

5       Scene or chase creation. 16

6       Tools. 22

6.1      Tool Tips Editor 22

6.2      Dip Switch. 23

6.3      DJ Buttons. 23

6.4      Control by a numeric keyboard. 24

6.5      Find a specific DMX channel in a project 25

7       Dialog windows description. 26

7.1      Main window.. 26

7.1.1      File menu. 28

7.1.2      Windows menu. 29

7.1.3      Configuration menu. 30

7.1.4      Help menu. 31

7.2      Attribute Setting. 32

7.3      Scene/chase Setting. 34

7.3.1      Scene Drift – insert any scene into current one. 36

7.3.2      Chase Drift – insert any chase into the current one. 37

7.3.3      Set Times – window for a global change of a fade-time between scenes in a chase  38

7.3.4      Fixture Setting – setting DMX addresses of lights. 39

7.3.5      Color Picker – color setting window.. 40

7.3.6      Color – Color picker window.. 41

7.3.7      Track Generator – Motion generator window.. 42

7.3.8      Select DMX Channels – DMX channels PAN and TILT – Axes X and Z  44

7.3.9      DJ Buttons – buttons not only for DJs. 45

7.3.10       DJ Control Setting. 46

7.3.11       DJ Buttons – File menu. 47

7.4      Graphic outputs. 48

7.4.1      DMX512 Output – graph of DMX512 output 48

7.4.2      Intensity Graph – Graph menu. 48

7.4.3      Scope Graph – special menu. 49

7.4.4      FFT Graph – Graph of an audio signal in a frequency area. 50

7.4.5      Graph of a selected attribute (with „show all“ on) 50

7.4.6      Debug Info – information on some basic calculations. 51

8       Attributes description. 52

8.1      Beat Detection I 52

8.2      Beat Detection II (disco) 52

8.3      Beat Detection III (rock) 52

8.4      Bass Level Output 52

8.5      Mid Level Output 53

8.6      High Level Output 53

8.7      Average Bass. 53

8.8      Average Mid. 53

8.9      Average High. 53

8.10       Primary Color Low.. 53

8.11       Primary Color Mid. 54

8.12       Primary Color High. 54

8.13       Average Volume. 54

8.14       Intensity in freq. 54

8.15       Intensity in time. 55

8.16       Intensity Threshold Average. 55

8.17       Intensity Threshold Instantaneous. 55

8.18       Max Power Detect 55

8.19       Frequency Saturation. 56

8.20       Dynamic Range. 56

8.21       Strobo Enabler 56

8.22       Move Volume Speed. 56

8.23       BPM (experimental) 56

8.24       Silent Detection. 57

8.25       Play Scene, Chase. 57

8.26       Auto (Test) 57

8.27       Strobo. 57

8.28       Submaster 57

8.29       Primary Color Contraposite. 58

8.30       Mid Speaker 58

8.31       Beat Detection IV (dynamic) 58

8.32       Strobo enabler style. 58

8.33       BPM II and III 58

8.34       Time Reloader 59

8.35       BPM III Speed Output 59

8.36       BPM III Fast Detect 59

8.37       BPM III Slow Detect 59

8.38       No Input Signal 60

8.39       Volume is Loud. 60

8.40       Volume is Quiet 60

8.41       Volume Rise. 60

8.42       Volume Fall 60

8.43       Volume Continuous. 61

8.44       External DMX IN.. 61

8.45       Scene Multiplier 61

8.46       Tone Detector 61

8.47       Frequency Speed. 62

8.48       No Beats. 62

8.49       Muffled. 62

 

 


1         Sound card setting

 

After turning DMX Music Visualization on, it is necessary to set up a sound card. The setting dialog box can be opened by pressing F3 or it can be found at the top menu of the main window of Music Visualization – item: Configuration>>Audio Setting.

 

 

Fig. 1 – Sound card settings

 

It is possible to choose any sound card for music analysis (item Select Sound Card) and any input that the analysis is being done on (item Select Record Input). The most important items that can be used for input are:

 

Microphone

- analysis is being done with a connected microphone

 

External source input (Line In)

- analysis can be done from the Line In of the sound card

 

Stereo Mix, Mono Mix, Wave

-         program analyses the music that is being played by any program on a PC (e.g. Windows Media Player, Winamp and others)

 

Inputs can be also configured in Volume control, which is a standard component of Windows. The Volume control window can be opened directly by clicking the Windows Mixer button in the Audio Setting window.

 

Some types of sound cards have nonstandard drivers. In this case the sound card needs to be configured with Windows Mixer or Volume control, respectively or using the drivers provided with the sound card.

 

Fig. 2 – Volume control

 

 

After selecting the right input or configuring its volume you must first click on Options, then properties and choose data record. Then you click on Select and set the desired volume.

 

After starting the program, the input previously selected in Audio settings window will be chosen but the volume of each input will remain unchanged.

 

         The basic analysis of a selected input will be shown in the Info Bar window. You can find information on Master volume there, which should be around the blue arrow, and the actual volume on various frequency bands.

 

Fig. 3 – Basic analysis

 


2         Adding an attribute (effect, symptom)

 

         In the lower part of the main window, there is a selection of music attributes, which then control the connected light technology/hardware. To try it out, you can first choose the attribute that shows the level of the overall volume – e.g. Intensity in freq.

 

 

Fig. 4 – Adding an effect

 

It can be added to the list of active attributes (effects) by clicking on + Add. The value of the attribute (volume in this case) will appear on the right side of it (in the Output column). You can control for instance a light intensity of a bulb or a motion of a scanner mirror. Each attribute has its own priority according to its location in the list. The attributes located lower in the list are of a higher priority therefore they can overwrite DMX channels values set by an above placed attribute. In practice you can use for instance a Beat Detection II attribute and assign a channel 10 to it. If you then use Silent Detection attribute somewhere lower and it was assigned channel 10 too and the attribute gets activated, it sets a value DMX channel 10 regardless of the value set by the previous attributes.

3         Attribute Setting

 

You can open the Attribute Setting dialog window by clicking on the name of an attribute in the list or by clicking the Setup button.

 

Fig. 5 – Attribute Setting

 

Choose DMX512 Output Channel to set any channel (range from 1 to 512) that will be controlled by the attribute (or effect). The final output will be shown in the DMX Output window and sent through the interface USB - DMX512.

 

 

Fig. 6 – DMX512 Output

 

An attribute can be assigned not only to just one channel, but also a whole scene or a chase (a continuous flow of scenes). Set the scenes in the Scene Setting window which is to be found in the Music Visualization main window in the Windows menu, then select Scene Setting. Saved scenes have a .sc extension and saved chases .ch extension. These files can be used in the Attribute Setting window if you choose Select Scene or Chase.

 

Fig. 7 – Scene or a chase assignment to an attribute

 

Setting of a given attribute is applied by clicking OK or Hold buttons. After clicking the Hold button the dialog window doesn’t close, however user settings will be applied immediately to the project. You can adjust the attribute using two sliders. What they represent depends on the chosen attribute and is further explained in the chapter „Attributes description“. Brief description of the basic meaning of the following slider types follows:

 

·        Threshold

Sets the sensitivity threshold. If there is any output lower than the threshold, the output is zero (for example with Beat Detection, Silent Detection, Move Volume Speed, Primary Color)

·        Output Force
Sets Output Force, e.g. multiplies the output value (for example with  Bass Level Output, Mid Level Output, High Level Output, Intensity in freq, Intensity in time, Average Bass, Average Mid, Average High, Sub master)

·        Backwardness Cutoff
Sets a delay for deactivating an output. However it doesn’t delay the activation of an output. (for example with Beat Detection, Strobo Enabler, Bass Level Output, Mid Level Output, High Level Output)

·        Lead Time
Sets leading time. (for example BPM attribute – in the current version is its value fixed on 100 ms)

·        Time to Active
Sets time delay for activating an output. Does not affect output deactivation (attribute No Signal)

·        Speed
Sets speed (for example with Move Volume Speed, Test, Strobo)

·        Pulse Ratio
Defines ratio of  activated state to deactivated state. (attribute Strobe)

 


4         How an attribute affects a scene or a chase

 

4.1       Assigning of one DMX channel

 

Only one DMX channel can be assigned to an attribute (item DMX512 Channel Output). The value of a DMX channel output will be the same as the value of an attribute output.

 

4.2       Scene assigning

 

         In case you need to control more than one DMX channel by a given attribute, it is necessary to create a scene. Use „Scene Setting“  window that is to be found in „Windows“ menu, then select „Scene Setting“. Or open it up by pressing ”F4”.

 

Fig. 8 – Scenes and chase creation window

 

You can create a concrete scene or a chase and save it as a file. More information on this is in the chapter Creating scenes and chases. This scene will appear while setting an attribute in „Alternatively Select Scene“ selection box. The attribute will affect values of nonzero DMX channels set in the scene. If an attribute has 100 % on the output, exactly this scene will appear at the DMX. If value of the attribute is lower, the values of the DMX channels will be proportionally lower. A scene can also be used for setting just one channel, if we want to limit maximal value of an output. If we need for example the „Beat Detection II“ attribute to affect only DMX channel number 10 and the output to be max 128 (e.g. 50 %) we create a scene where we set a channel number 10 to 128 and select this scene while setting attribute (in „Attribute Setting“ dialog window, item „Alternatively Select Scene“).

 

4.3       Chase assigning

 

         If it is needed to control not just one static scene, but a whole sequence of scenes (e.g. a concrete motion of scanner mirrors, gradual color changes etc.) you need to use a chase.

Chase is a succession of scenes, where Fade Time is duration of transformation of one scene into another. More about chase creation is in the chapter Creating scenes and chases. The final chase can also be assigned to an attribute in„Alternatively Select Scene“. Values of the output will depend on the type of the chase, see below:

 

Chase contains nonzero times (Fade Time)

 

An attribute affects a speed of a chase. If a speed of an attribute is 100%, a speed of a chase will correspond to the times set in Fade Time, if not, then the speed will be proportionally lower. If the output is zero, the chase will stop (values of given DMX channels will stop changing, but they will be at the output). If the „Play On Threshold“ box is checked (it checked by default) then with a zero output, there will be zero outputs on given DMX channels. These channels will be able to control the attributes that are placed higher on the list.

 

Fig. 9 – Assigning a chase to an attribute

 

Chase contains more than 2 nonzero scenes

 

         An attribute switches between individual scenes. Everytime an attribute goes over 128 (50%) it switches to a following scene (hysteresis 4 %) Therefore you can set individual colors of a chase and switch between them by an attribute „BPM II“.

 

Chase contains exactly 2 scenes with zero time

 

         In this case it is a typical cross-fade between 2 scenes. If value of the output is zero, the output will be the first scene of a chase on the output.

If the output value of an attribute is increasing, the first scene transforms into the second scene and if the output value of an attribute reaches 100 % there will be only the second scene saved in a chase. Switch to cross-fade mode is automatic, it happens when a chase contains 2 scenes with zero times. To stop the cross-fading you can copy both scenes to a chase. A new chase with four scenes will appear and the program will treat them as it was described above.

 

4.4       Assigning of symbols # and ##

 

         An attribute does not have to affect just output of DMX channels, but it can also affect output of another attribute. If you enter # symbol in „DMX512 Channel Output“, it means that the attribute will be affecting the following attribute. If you use for instance „Strobo“ attribute and as a DMX channel you set the # sign  then set  „Average Volume“ as a following attribute, the output of the attribute „Average Volume“ will do the strobo effect. In case an attribute needs to affect another attribute inversely (turn it off) you can just use two ## signs. You can substitute # or ## for a number that defines how many following attributes are supposed to be affected.

 


5         Scene or chase creation

 

         To create a scene or a chase use „Scene Setting“ window, which is to be found in „Windows“ menu. You can close the dialog window by pressing F4. Here you can create a concrete scene or a chase and save it as a file. Left part of the window is for scenes and right one for chases.

 

Fig. 10 – Scene or chase setting

 

Meanings of individual buttons for scene setting are as follows:

 

Save Scene

Saves a scene as a file under the name written in the edit box (Scene1 by default).

 

Load Scene

Loads a scene of the name written in the edit box (Scene1 by default).

Open File

Opens a dialog window, where you can choose a scene file, and loads the scene.

 

Insert File

Inserts a scene from a file into the current file (you can connect more scenes). Inserts only nonzero channels and the other channels remain unchanged. While inserting you can also set a different origin for a scene. The number of the first used channel in a scene will appear in „Set first DMX512 channel (1 to 512)“ and you can change the channel or you can set a displacement from the original DMX channel in „Set drift origin scene (-511 to 511)“. It is appropriate while setting light of the same kind but with a different origin. You can also insert an inverted scene by checking the „Invert scene“ box.

 

Fig. 11 – Inserting a scene

 

All ON

Sets all the DMX channels in the scene to 255 (100%).

 

All Test

Sets all the DMX channels at the output to the full value of 255 (100%). The button does not affect the scene.

 

Clear Scene

Clears all values in the scene.

 

Color Picker

A dialog window for choosing a color. The color will be inserted into the scene as a combination of RGB or CMY.

 

Active

Activates the scene that is being set up. There will be all nonzero channels from the scene at the DMX512 output.

 

Solo

If you check this box then only data from this dialog will be sent to the DMX512 output when the „Active“ (or „Play Chase“) button is activated.

 

Patch

Switches from a mode that controls all DMX channels to a mode that controls only the channels selected by „Fixtures“ buttons. The first fader always controls the first DMX channels of selected lights and the following fader controls the following DMX channels of selected lights. 

 

Fixtures

These buttons will appear in a patch mode, when you click on the „Patch“ button. You can set one light effect to every individual button. Right click opens an address setting and attribute name dialog window (more in Dialog windows description). Left click will include (its text is in bold) or exclude an item from the list of controlled attributes.

 


DMX IN

If one of the connected interfaces is selected as Interface IN (main dialog: „Configuration>>Interface IN”), then the incoming data will be displayed directly through faders.

 

Meanings of individual buttons for chase setting are as follows:

 

Add Scene

Adds the current scene into a chase with a time stated in Fade Time. The name of inserted scene will be stated in the chase but is not saved in the chase file.

 

Update

Updates the selected scene in a chase according to the currently selected scene in the left part of the window including Fade Time.

 

Set Times

Sets the time set in Fade Time to all scenes in a chase. (if confirmed by clicking „Yes“) or only to a selected scene (if confirmed by clicking „No“).

 

Scene On

The current scene will be set according to a scene selected in a chase. You can also do it by double clicking on a scene directly in the chase.

 

Remove One

Removes the currently selected scene from a chase.

 

Remove All

Clears the whole chase.

 

 

 

Track

Opens a dialog window for motion trace creation. If it is necessary to send the trace that is being created to DMX 512 output as well, it is necessary to activate the output of the scene („Active“ button) and to select „Scene on“ in the Track window. More on this in chapter Dialog window description.

 

Play Chase

Plays chase directly to DMX512 output. Can be combined with „Solo“.

 

Save Chase

Saves a chase as a file under the name written in the editing box (Chase 1 by default).  The names of scenes are not being saved. The scenes are numbered according to their position in the sequence if opened.

 

Load Chase

Loads a chase of the name written in the editbox (Chase 1 by default).

 

Open File

Opens a dialog window, where you can choose a chase file, and loads the chase.

 

Insert File

Inserts a chase from a file into the current chase (it is possible to connect more than one chase). Only nonzero channels will be inserted, the other ones will remain unchanged. You can set a different origin of chase while inserting it. In the window „Set first DMX512 channel (1 to 512)“ the number of the first used channel appears. You can change it to any other or you can just set a drift from origin in „Set drift origin scene (-511 to 511)“. It is useful while setting light effects of the same kind with a different origin. You can also insert an inverted chase by checking the „Invert scene“ box. The times remain the same as stated in the current chase. If there are more scenes in a chase the surplus joins the end of the current chase. If you check the „Append Chase“ box the inserted chase will be attached to the end of the current chase. 

 

Fig. 12 – Inserting a chase

 

Hot keys

Left and right arrow – move selected blocks of DMX channels

Enter if there is any active fader, the Add Scene button will be pressed (inserts a scene that is being edited into a chase). 

 


6         Tools

 

         There are some additional dialogs in „Windows“ menu to make settings easier or to help with using lighting technology.  The dialog windows are described in more detail in the Dialog windows description chapter.

 

6.1       Tool Tips Editor

 

         This tool helps with editing individual DMX channels. You can put down a function of each channel. These notes appear in the Scene Settingwindow at each individual fader. The note will be shown in a relevant „tool tips“ box if you point at a fader with a mouse. The tool „Tool Tips Editor“ is to be found in „Windows“ menu.

 

      

Fig. 13 – Tool Tips Editor

6.2       Dip Switch

 

         This tool to helps with setting an address of a light effect. It generates a configuration of DIP switchers based on inserted numeric value the way it has to be set on a light effect. You can use it also the other way around. „Dip Switch“ is to be found in „Windows“ menu.

 

Fig. 14 – Dip Switch

 

6.3       DJ Buttons

 

         Dialog window with buttons especially for DJs that need fast access to previously defined effects. „DJ Buttons“ is to be found in „Windows“ menu. If the buttons in a project are defined this dialog window will automatically open after opening this project. You can assign not only a concrete scene (.sc) or a chase (.ch) to individual buttons but you can also choose a whole project (.vis) that will open after pushing a button. If you open another project the current one will be saved. You can also assign an individual project that contains only configured buttons (.dj) to a concrete button and switch this way between lists of buttons. A window for a button configuration will open up by right clicking on it. Left clicking activates or deactivates a button. If there was another button active at the same time it will be deactivated. If you check the „Enable NUM Keyb” box in the „Configuration” menu you can control the first 10 buttons with numeric keyboard. It is ideal to use a wireless numeric keyboard. Leave number 0 empty because then, by pressing it, you can easily deactivate all the buttons even without their current state being visible. If you assign a chase with zero Fade Time to a button, then you can switch between individual scenes by pushing space button or if you are using numeric keyboard by pressing the „Del“ key.

 

Fig. 15 – DJ Buttons

 

6.4       Control by a numeric keyboard

 

You can find this feature in „Configuration” menu, select „Enable NUM Keyb”. It works independently on an application currently being used, therefore it is necessary to keep in mind that if this feature has been enabled you can‘t use a numeric keyboard for typing. Functions of the numeric keyboard are defined as follows:

 

Numbers 0 to 9:            Correspond to the first ten of DJ Buttons.

Del“ key:                    Scene switching in a chase (if a fade time is 0) on an activated DJ button (the same meaning as a space key).

„*“ key:                        Stops a DMX output (i. e. presses Fixed DMX button in the main window).

„+“ and „-“ key:          Volume control (depends on a program version).

 

6.5       Find a specific DMX channel in a project

 

Select „Find DMX Channel“ function in the „Windows“ menu to find, where a specific channel was used. Type in a value of a channel and after confirming by pressing OK a list of all scenes and chases used in a project that affect the channel shows up. This feature is particularly useful with bigger projects where you later need to find all parts where a specific feature of a specific light is affected.

 


7         Dialog windows description

 

         This chapter briefly describes individual dialog windows included in the program. It describes meaning and functions of the operating elements.

 

7.1       Main window

 

Fig. 16 – Main window

 

 


Music Visualization application window description:

 

1.       Main program menu.

2.       List of active attributes.

3.                Name of an assigned scene, chase or given DMX channel, that is affected by the attribute.

4.       Hot Buttons to activate/deactivate an attribute:

ButtonON

Output is controlled by an attribute

ButtonFULL

Output is permanently activated (left mouse button)

ButtonOFF

Output is deactivated (right mouse button)

5.       Last button permanently activates or deactivates an output of all attributes at the same time.

6.       List of available attributes.

7.       Remove selected attributes („Del“ key).

8.       Remove all attributes.

9.       Initialization of selected attributes.

10.     Remove an assigned scene or a chase from selected attributes.

11.     Copy the current attribute and insert it below itself.

12.              Open dialog window with attribute setting (the same as a double click on a name of an attribute).

13.     Move an attribute one line lower in the list

14.     Move an attribute one line higher in the list

15.     Add an attribute to the list

16.     Set the entire DMX512 output to zero („blackout“).

17.     Stop visualization output. Attribute calculations will keep running.

18.     Stop/start visualization.

19.     Output value of an attribute.

 

7.1.1    File menu

 

menuFile

Fig. 17 – File menu

 

Meaning of items in the file menu:

 

New Project          – Create a new project (included DJ Buttons, Fixtures)

Open Project        – Open a project

Insert Project        – Insert a different project after the end of the current one

Save Project         – Save the current project

Save Project As… – Save the current project to a specified file

Close                     – Close the program

 


7.1.2   Windows menu

 

menuWindows

Fig.18 – Windows menu


Meaning of items in the windows menu:

 

Scene Setting                Scene Settingwindow to create new scenes and chases (see chapter 5) 

Info Bar                         information window Info Bar

DMX512 Output           DMX512 output window

DMX512 Output Graph      output graph of all 512 DMX channels

Basic Calculations        – window for some pre-made calculations

Audio Graphs                show audio signal graphs

Tool Tips                      show window to create notes to DMX channels (see chapter 6.1)

Find DMX Channel      find a DMX channel in a project (see chapter 6.5)

Dip Switch                     a tool to help with DMX address setting (see. chapter 6.2)

DJ Buttons                    DJ buttons (see chapter 6.3)

 

7.1.3   Configuration menu

 

menuConfiguration

Fig. 19 – Configuration menu

 

 

Meaning of items in the configuration menu:

 

Audio Setting                – audio input Setting window

DMX512 Output                    – DMX512 Output modes

mode 1:  Optimized mode working with the first 256 channels. Calculations are processed every 20 ms.

mode 2:  Slower mode working with the first 380 channels. Calculations are processed every 30 ms.

mode 3:  Mode working with all 512 channels. Calculations are processed every 30 ms.

mode 4:  Special slow mode for lighting technology that is not quite compatible with DMX 512 (for example EL line set of lasers from Laserworld). Marks are being inserted between individual frames (MABF Mark Between Frames). Only the first 18 channels are being sent. Other 160 channels are in normal mode 1 (depends on the program version)

Interface OUT            – interface used for DMX* output

Interface IN                – interface used for DMX* input

LPT Port OUT                    output of the first 8 (demo 6) channels over LPT port (works only in the switching mode when a DMX value lower than 127 means off and higher on)

Reserve Audio Input Fast switch to a reserve audio input set in „config.dat“ file

Enable NUM Keyb   Allows direct control with a numeric keyboard

                                    (See chapter 6.4)

 

* Selected devices will be saved after a program terminates. After turning the program back on, the same devices will be selected regardless of the used USB ports.

 

7.1.4   Help menu

 

menuHelp

Fig. 20 – Help menu

 

Meaning of items in the help menu:

 

Help                        – Application manual

Online Help            – Updated manuals available online

Register Product… – Product registration

Upgrade                 – Direct link to the latest version

About                     – About dialog

 

7.2        Attribute Setting

 

How to use the „Attribute Setting” window is described in the chapter 3. Attribute setting

 

Fig. 21 – Attribute Setting dialog window

 

Attribute Setting window description:

 

1.       List of all available scenes and chase (chase, i. e. a continuous flow of scenes).

2.       Type of an output attribute:

chase   –if a chase has been selected  (automatically right after selecting a file ending with .ch )

scene   – if a scene has been selected  (automatically right after selecting a file ending with .sc )

number    – affects only the DMX channel selected by a user (value 1 to 512)

#         – output affects a following attribute (see chapter 4.4)

##       – output inversely affects a following attribute (see chapter 4.4)

3.       Opens Scene Setting window for editing a selected scene or a chase.

4.       Deactivates attribute’s output

5.       Allows zero value at an output of an attribute

6.       The meaning of this check box is changing according to the selected type of an output:

DMX channel or a scene:

Inverted output       – the attribute’s output is inverted

Chase:

Play on threshold        – values of DMX channels are sent to an output only if attribute’s output is > 0.

7.       Data received from a different DMX machine (lighting console) will be used as a scene.

8. and 9.      The meaning of the sliders depends on the concrete attribute. It is described either in chapter 3 or directly in the notes for each individual attribute in chapter 8. The following functions are the most common:

Output force                 – Output force in [%].

Threshold                     – If a value is below this threshold the output is permanently zero.

Backwardness cutoff    – Delay of an attribute’s deactivation in [ms] or in [s].

Speed                            – Speed of an attribute in [%].

10.     Button for a graphic visualization of an output in time.

11.     Close the window without saving changes

12.     Close the window without and save changes

13.     If the Hold button is activated all the changes automatically apply, if the Hold button is deactivated the setting applies after pushing OK button or pushing the Hold button again.

 

7.3        Scene/chase Setting

 

How to use the window is described in chapter 5.

 

Fig. 22 – Dialog window for scene/chase setting

 

Scene Setting window description:

 

1.          Values of individual DMX channels.

2.          Selects a block of 16 channels out of total 512 to edit.

3.          Static scene setting:

Save Scene/Load Scene – Save Scene/Load Scene in a current name

Open File/Insert File    – Open/insert by the a help of a file selection window

 

All ON               – All DMX channels set to a maximum (255/100%)

Color Picker     – Allows to directly mix a color (for LED reflectors and RGB/CMY switchers)

Clear                 – Clears all DMX channels

Patch                 – Mode switch between direct DMX channels setting and setting of selected Fixtures only (light effects). In the patch mode you can select individual lights and control them all at once. The first fader corresponds with the first DMX channel of each individual light.

Active                – the scene that is being edited also projects on a DMX output.

Solo                   – only a scene or a chase that is being edited is at the DMX output

DMX IN            – faders show a scene that is being received from an external device through DMX PIPE (you can select a receiver of DMX512 in Configuration>>Interface IN in the main window menu. If there has been no device selected in Interface IN this option is not available.

4.          Functions to create chase (scene sequencing):

Fade Time           – time between two scenes

Add Scene           – add a static scene into a chase with a time chosen in Fade Time

Update                 – A selected scene in a chase will be set according to a scene created in the left part of the window

Set Times            – set time for one or the entire chase

Scene On             – transfers a selected scene in a chase into the left part (the same as a double click)

Remove One       – remove selected scene from a chase

Remove All         – delete the entire chase

Track                  – open a window to create a motion path (more on this in chapter 8.4)

Play Chase          – play created chase. It’s possible to combine it with Solo button.

Insert /Open File – Open/insert with the help of a file selection window

Save/Load Chase – Save Scene/Load Scene of the current name

5.          Features:

Right click          – opens a dialog window for editing the name of a light and its address of origin and ending (Fixtures).

Left click             – activates/deactivates a set light that is then controlled together with other selected lights from the first address

 

Specially configured keyboard functions in Scene Setting window:

 

Arrows ←, → – switch selected block of 16 out of 512 available channels

Enter button        pushes Add Scene button while editing a scene

 

7.3.1   Scene Drift – insert any scene into current one

 

A window opens up after pushing Insert File button in Scene Setting window, part for editing scene.

Fig. 24 – Dialog window to insert/drift a scene

 

1.                 The first DMX channel used in a chase. You can change it to any other channel, which will shift the entire scene.

2.                 Absolute drift of the inserted scene.

3.                 Individual DMX channel values are inserted inversely.

 

7.3.2   Chase Drift – insert any chase into the current one

The window opens up by clicking Insert File in Scene Setting window in the part for editing scene.


1.     The first DMX channel used in a chase. You can change it to any other channel. This will shift all the scenes of the chase that is being inserted.

2.     Absolute drift of all inserted scenes in the chase that is being inserted.

3.     Individual DMX channel values are inserted inversely.

4.     Inserted chase is attached to the current one.

 

If inserted this way the fade-times between individual scenes will remain unchanged as defined in the current chase.

 

7.3.3   Set Times – window for a global change of a fade-time between scenes in a chase

 

Window opens after pushing Set Times in Scene Setting window

 

Fig. 25 – Confirmation dialog for a change of fade time between scenes

 

Meaning of buttons in fade time dialog window (Fig. 25):

 

Yes     – change all times in a chase to the value defined in Fade Time box

No       – change time only for a selected scene in a chase

Cancel – no changes


7.3.4   Fixture Setting – setting DMX addresses of lights

 

By right clicking on a selected fixture in the Scene Setting window you open up a fixture setting window.


Window description:

 

1.                 Button text

2.                 First DMX address of a light

3.                 Number of DMX channels for a light

4.                 Clear fixture (clears light effect setting)

5.                 Confirm setting

 

When you edit the following Fixtures button the first available address will be set as its first address (which is the previous starting address + the number of DMX channel for the previous light) and number of DMX channels will be the same as at the previous one.


7.3.5   Color Picker – color setting window


                                                                           

 

Window description:

 

1.                 DMX channels of individual colors

2.                 Color intensity (0-255)

3.                 Open a color picker window

4.                 Switch between RGB and CMY mode


7.3.6   Color – Color picker window


Window description:

1.                 Select a predefined color or a color that that you want to edit

2.                 You can choose a color from the color palette

3.                 Change saturation of the selected color by moving the slider

4.                 Adds the selected color to My colors (to the field number 6)

5.                 Confirm changes – OK, cancel changes – Cancel


7.3.7   Track Generator – Motion generator window

 

Fig. 29 – Chase track window

 

Dialog window:

 

1.                 Layout of individual scenes

2.                 Current scene

3.                 Position data of the current scene

4.                 Current scene/total number of scenes

5.                 These buttons depend on the state of „+10“ and „Get All“ options

Size In                            – shrink towards the absolute center

Size Out                          – expand towards the absolute center

Up, Left, Down, Right    – move in given directions

6.                 Time         – time of a transfer to a current scene

Insert       – insert a new scene into a chase (new scene is inserted implicitly as set in Scene Setting)

Remove    – remove the current scene

Set Path   – set a predefined path, for example:

                 Circle – circular path

                 Ellipse – elliptical path

                 Center – puts the current node to the center

                 Diagonal 1 a 2 – sets nodes diagonally

                 Line Hor. – sets nodes horizontally

                 Line Ver. – sets nodes vertically

                 Doubled – doubles the nodes (i. e. there will be stops in doubled nodes)

                 First pos. – puts the current node to the location of the first one

                 Half Size – deletes every other node

                 Previous pos. – puts the current node to the location of the previous one

                 Random – puts nodes to random locations

                 Square – arranges the first four nodes into a square

                 ZigZag – Zigzag track

7.                 Set DMX channels for individual X and Y axes of a motion X and Y

8.                 Track will be generated inversely into the chase

9.                 Currently selected scene

10.             x 10          – Operations are performed with 10x zoom

 Get All      – Operation is performed with all scenes at the same time

 Scene On – Currently selected scene will be shown in the Scene Setting window

 

If the option Scene On is active and the Active button is pressed in Scene Setting, the currently edited scene will be on the DMX 512 output.

7.3.8   Select DMX Channels – DMX channels PAN and TILT – Axes X and Z

 

If you press Axis X or Axis Y buttons, a window for selecting all X axes (PAN) or all Y axes (TILT), which are used to generate motion paths, shows up.

 

DMX addresses tagged like this are already selected for the second axis

 

selected DMX addresses that will be used for generating a chase

 

It is possible to define more addresses at the same time and therefore control more devices at the same time.


7.3.9   DJ Buttons – buttons not only for DJs

 

Simple buttons for a fast access to previously sets scenes, chases or any other projects. These buttons have higher priority than attributes. If they are activated they overwrite values set in the main window but not the values set in the Scene Setting window.

 

Fig. 31 – Example of DJ buttons

 

 

Description of a basic DJ Buttons dialog window:

 

Menu File – insert or open settings from different projects (see chapter 7.3.11)

Menu Setting – select the number of buttons shown (4, 8, 12, 16, 20, 24)


DJ Buttons can be set or edited as follows:

Left click – activates the assigned file

Right click – opens a window for DJ button setting

 

 

 

DJ buttons can be assigned the following file types:
 

.dj – a file containing a list of buttons. If activated the current one will be overwritten by the list saved in this file.


.sc
– a static scene. If activated this scene shows up at the output.


.ch
– a sequence of scenes with defined times (a chase)

If the times are higher than 0, the scenes fade into one another in that time. If they are 0, the current scene will be shown until the space bar is pressed which will change the scene into the following one in the given list (chase).


.vis
– an entire project. If activated, the whole project opens up (together with the DJ buttons (if they are included with the project). Before that a current project will be automatically saved without asking.

 

7.3.10                    DJ Control Setting


DJ Control Setting window description:

 

1.                 Name of a button

2.                 File used– you can assign following file types to a button:

a.            Scene (.sc)

b.           Chase (.ch)

c.            Entire project (.vis) – in case of using a different project the current project is automatically saved.

d.           A different list of buttons (.dj).

3.                 If this box is checked, only the selected program will be playing after pressing a DJ button. This feature is active only if a scene or a chase has been selected.

7.3.11                    DJ Buttons – File menu

menuDJButtons

Fig. 33 – File menu

 

Meaning of individual items in the file menu is as follows:

 

Open from File     – open DJ buttons from a file

Save to Extra File        – save selected DJ buttons to a special file (they save into a project by default)

Clear                     – clear DJ buttons

Close                     – close dialog window (buttons’ state is preserved after re-opening)


7.4       Graphic outputs

 

7.4.1   DMX512 Output – graph of DMX512 output

Textové pole: Fig. 34 – Preview of graphs of outputs of all DMX512 channels

1                2    3

 

 


DMX512 Output dialog window description:

 

1.                 Minimal and a maximal value of DMX channels in [%]

2.                 Current value of DMX channels [0 – 255]

3.                 Channel where a mouse pointer is at

 

 

7.4.2   Intensity Graph – Graph menu

Fig. 35 – Preview of a graph of volume intensity

 

Meaning of items in the Graph menu:

 

It is possible to switch between individual graphs:

FFT                 – Intensity in a frequency area

Intensity           – Volume intensity

Special             – Dynamic volume intensity

Freq Intensity – Sum of all intensities in a frequency area

Scope               – Audio signal in a time area

STOP              – Stops graph rendering

Exit                  – Closes a graph

 

7.4.3  

Scope Graph – special menu

Textové pole: Fig. 36 – Preview of a graph of an input audio signal in a time area

 

Meaning of items in file menu:

 

1.                 Displayed time scale

2.                 Size of an amplitude showed

3.                 Option for showing some additional calculations

 

7.4.4  

FFT Graph – Graph of an audio signal in a frequency area

 

Textové pole: Fig. 37 – Preview of a graph of an audio signal (FFT)

1.                 Minimal and maximal volume

2.                 Volume value for the current mouse position

3.                 Selected frequency according to mouse position

 

7.4.5   Graph of a selected attribute (with „show all“ on)

 

Fig. 38 – Graph of a selected attribute

 

7.4.6  

Debug Info – information on some basic calculations

Textové pole: Fig. 39 – Information on some basic calculations

 

Window description:

 

1.                 Minimal value, maximal value

2.                 Current output volume

3.                 Average volume

4.                 Values of an automatic equalizer

5.                 Status of an automatic volume calibration

6.                 Resets minimal and maximal values

7.                 Refresh rate


8         Attributes description

 

8.1       Beat Detection I

This attribute detects output level of low frequencies from 40Hz to 220Hz. If the set threshold is crossed a maximal value will appear and remains there until the volume drops below the threshold again but not earlier then the time set in Backwardness Cutoff is up. If there is a long low frequency sound in the music, the output of this attribute will be active for the same amount of time.

 

8.2       Beat Detection II (disco)

         It is a more sophisticated algorithm then Beat Detection I. It ensures that the detection will turn off after a time set by Backwardness Cutoff slider and another one is not earlier than double of that time. This algorithm is independent on a volume, but you can set a threshold, below which the output will be permanently zero.

 

8.3       Beat Detection III (rock)

         A different algorithm than Beat Detection II, but with almost the same result.

 

8.4       Bass Level Output

         Allows only volume with low frequency to the output (from 40Hz to 300Hz, through exponential function). Threshold for output values is set by moving Output Force slider and delay by Backwardness Cutoff slider. After the end of the delay, the output will be lower again.

 (Some powerful light bulbs need more than a short impulse to turn on and that is why you can prolong it by moving Backwardness Cutoff slider).

8.5       Mid Level Output

The same as Bass Level Output, but for frequencies from 300Hz to 5100Hz.

 

8.6       High Level Output

         The same as Bass Level Output, but for frequencies from 5100Hz to 11050Hz.

8.7       Average Bass

         There is an average volume of low frequencies at the output. By moving the Output Force slider, you can set the output level.

 

8.8       Average Mid

         There is an average volume of medium frequencies at the output. By moving the Output Force slider, you can set the output level.

 

8.9       Average High

         There is an average volume of high frequencies at the output. By moving the Output Force slider, you can set the output level.

 

8.10  Primary Color Low

         This algorithm calculates the amount of low frequencies and in case it is higher than the amount of other frequencies, it activates PERMANENTLY until the values drop again. By moving the Output Force slider, you can set the detection threshold (the higher the more frequent the detection is). In practice the appropriate value is approx. between 30% and 35%. The attribute is suitable for instance for selecting a primary color in a scene (low freq. red, high freq. blue etc.) or it is possible to set a specific motion of scanners (low freq. motion on the ground, high freq. on the ceiling etc...) via a chase (assign a .ch file type).

 

8.11  Primary Color Mid

         The same as Primary Color Low, but for medium frequencies. Suitable value is between 35% and 40%, but it depends on desired frequency of its initiation as well.

 

8.12  Primary Color High

         The same as Primary Color Low, but for high frequencies. Suitable value is between 40% and 50%, but it depends on desired frequency of its initiation as well.

 

8.13  Average Volume

         There is an average volume value at the output. By moving the Output Force slider, you can set the output level. The Speed slider sets the speed of averaging.

 

8.14  Intensity in freq

There is immediate volume intensity at the output (calculated from frequency area by the FFT sum). The output is a bit more dynamic than a real volume value calculated from a time area (Intensity in time) and is slightly dependent on a number of FFT frequencies. By moving Output Force slider, you can set the output level and by moving Backwardness Cutoff slider, you can set the delay after which the output drops again. Preferable over Intensity in time.

        

8.15  Intensity in time

There is immediate volume intensity at the output (calculated from time area). Output matches real output power value. By moving the Output Force slider, you can set an output level.

 

8.16  Intensity Threshold Average

It gets activated in case the average volume value overcomes threshold set by the Threshold slider and gets deactivated after the amount of time set by the Backwardness Cutoff slider in case the average volume value is below the threshold again.

 

8.17  Intensity Threshold Instantaneous

It gets activated in case the current (immediate) volume value overcomes threshold set by the Threshold slider and gets deactivated after the amount of time set by the Backwardness Cutoff slider in case the average volume value is below the threshold again.

 

8.18  Max Power Detect

         Detects very high load peaks that are very rare. The frequency of detection is dependent on the Threshold slider setting. In practice it is often better to use Strobo Enabler attribute instead.

 

8.19  Frequency Saturation

         The output is an “amount” of frequencies present in the music.

 

8.20  Dynamic Range

         The output is a value representing dynamic range of the music.

 

8.21  Strobo Enabler

         A popular attribute that detects incoming beats with the condition that they haven’t been present in the music for some time (Incoming beats detection). It can turn anything on – a stroboscope, laser, light bulb, fast motion etc. The Threshold slider sets threshold for its activation (lower value = more frequent activation). The Backwardness Cutoff slider determines the amount of time for which the attribute is active after detection.

 

8.22  Move Volume Speed

It is an Auto attribute, where the speed is influenced by volume. The speed to volume ratio is set by the Speed slider and the volume threshold is set by the Threshold slider. If the volume is below the threshold, the attribute gets deactivated. Suitable for initial motion of a scanner mirror, color or gobo selection. Best placed in the beginning of a project, then the set DMX channels can easily overwrite the attributes located lower.

 

8.23  BPM (experimental)

Rhythm detection. This algorithm has been surpassed by BPM III algorithm.

8.24  Silent Detection

         A useful algorithm for any project. Detects low volume. It is especially useful for light behavior setting, when music stops playing or when it plays at a very low volume. The threshold for its activation can be set with the Threshold slider. It is appropriate to place this attribute at the end of a project (where it has higher priority – it overwrites other DMX channels while activated) but before the Strobo Enabler.

 

8.25  Play Scene, Chase

         Output permanently switched on.

 

8.26  Auto (Test)

         The output is a value linearly growing up to a maximum and then back to minimum with a speed set by the Speed slider.

 

8.27  Strobo

         The output is not controlled by music. This attribute switches between the maximal value and the zero value at the output with the speed set by the Speed slider. The ratio of the length of the maximal value to the length of the minimal value can be set with the Pulse Ratio slider.

              

8.28  Submaster

         There is a value at the output set by the Output Force slider.

 

8.29  Primary Color Contraposite

         This attribute gets activates in case the average quantity of medium, low and high frequencies is similar. Tolerance can be set by the Output Force slider.

 

8.30  Mid Speaker

         This attribute works with medium frequencies around range of human voice. The output is alternation of zero and maximal value in case of crossing the threshold set by the Threshold slider.

 

8.31  Beat Detection IV (dynamic)

         Another type of beat detection similar to Beat Detection II and III.

 

8.32  Strobo enabler style

This attribute analyses style of the music (based on information from Freq. Saturation, Dynamic and frequency ratio) and in case the song seems suitable for stroboscope it gets activated. The threshold for activation can be set by the Threshold slider.

 

8.33  BPM II and III

         This algorithm searches for BPM value of the music. In case it is sure about rhythm stability (the music is rhythmical) it gets activated. The threshold can be changed by moving the Threshold slider. If it is set up to 70%, for example, it gets activated only if the music has heavy rhythm. The output is the detected rhythm (BPM value). Heads up, this is the only attribute, which activates Zero Output on its own and after its deactivation, this option becomes available again.  You can also assign a chase with zero times to this attribute. The individual scenes in the chase will then be switching according to the detected beats. The quality of the BPM III detection is displayed in the Info Bar window only in case this algorithm is used (e.i. if it is on the list of active attributes).

 

8.34  Time Reloader

         You can assign to it a specific name of a project that should get opened after certain amount of time or you can set a value for how long after opening of this project should a new one get opened. This attribute can be switched on using another attribute by # (see chapter 4.4).

8.35  BPM III Speed Output

The speed of a rhythm is at the output. This attribute gets activated if the detection quality is higher than the one set by moving the Threshold slider (the same as with BPM III). The output level can be adjusted by the Output Force slider.

8.36  BPM III Fast Detect

         The meaning of both Threshold and Output Force sliders is the same as in BPM III Speed Output. This attribute gets activated in case the target speed (the same value as the BPM III Speed Output has) is higher than 50%. Higher value of Output Force results in lower detection frequency.

 

8.37  BPM III Slow Detect

The meaning of both Threshold and Output Force sliders is the same as in BPM III Speed Output. This attribute gets activated in case the target speed (the same value as the BPM III Speed Output has) is lower than 50%. Higher value of Output Force results in higher detection frequency.

 

8.38  No Input Signal

         This attribute gets activated, if there is no signal at the output for an extended period of time. The threshold boundary for intensity can be set by the Threshold slider.

 

8.39  Volume is Loud

         Detects loud signal. The Threshold slider determines the detection threshold (frequency of activation). Higher threshold results in more frequent detection.

 

8.40  Volume is Quiet

Detects silent signal. The Threshold slider determines the detection threshold (frequency of activation). Higher threshold results in more frequent detection.

        

8.41  Volume Rise

Detects increasing volume. The Threshold slider determines the detection threshold (frequency of activation). Higher threshold results in more frequent detection.

 

8.42  Volume Fall

Detects decreasing volume. The Threshold slider determines the detection threshold (frequency of activation). Higher threshold results in more frequent detection.

8.43  Volume Continuous

         Detects constant volume. The Threshold slider determines the detection threshold (frequency of activation). Higher threshold results in more frequent detection.

8.44  External DMX IN

         There is a value of a concrete DMX channel that is being received from an external board at the output of this attribute. The specific DMX channel can be chosen by moving the DMX Channel slider. Using the Output Limit slider, you can limit the maximal value of this output.

 

8.45  Scene Multiplier

This attribute does not acquire data from the music. It is a tool for editing values of DMX channels. It can limit or turn up a DMX channels specified in an assigned scene. It influences only values of DMX channels that are generated in a list above this attribute. It is effective to activate this attribute by another one (using # and ##, see chapter 4.4) or for an additional limitation of the output of concrete channels. This attribute can also deactivate channels, which value is lower than a value set by the Threshold slider.

 

8.46  Tone Detector

         Indication of the volume of a specific tone. The sound spectrum from 30Hz to 10kHz is divided into 256 intervals and in each of them you can indicate its volume. A specific tone can be chosen by the Tone slider. The force of the output can be adjusted by moving the Output Force slider. The attribute is suitable for visualizing one chosen instrument.

 

8.47  Frequency Speed

Measures how many times the signal crossed zero in the time area. This roughly indicates carrier frequency magnitude.

 

8.48  No Beats

If the will be no low frequencies present in the music for the time set by the Time To Active (2s by default)slider, this attribute will activate until the low frequencies reappear. The sensitivity of detection can be determined by the Threshold slider (the higher its value, the more frequent will the detection be).

 

8.49  Muffled

This attribute detects, when a frequency band is present only in small amounts (low, middle or high frequencies). If this condition is met it stays active for the length of time set by the Threshold slider (the higher its value, the more frequent will the detection be).